Un motore di ricerca WordPress per sviluppatori e autori di temi



is_lighttpd_before_150 ›

Da2.5.0
Deprecaton/a
is_lighttpd_before_150 ( Nessun parametro )
Ritorna:
  • (bool) Whether the server is running lighttpd < 1.5.0.
Definito a:
Codex:

Is the server running earlier than 1.5.0 version of lighttpd?



Funzioni correlate: is_allowed_http_origin

Sorgenti

function is_lighttpd_before_150() {
	$server_parts    = explode( '/', isset( $_SERVER['SERVER_SOFTWARE'] ) ? $_SERVER['SERVER_SOFTWARE'] : '' );
	$server_parts[1] = isset( $server_parts[1] ) ? $server_parts[1] : '';
	return  'lighttpd' == $server_parts[0] && -1 == version_compare( $server_parts[1], '1.5.0' );
}